Solar Squeeze

Shorts are also vulnerable in CSIQ, ESLR, JASO, etc